Hi Friends,

My sole purpose to start this forum is to unite all TUV 300 owners to share their experience no matter good or bad, to benefit others and bring niggles till Mahindra officials.

Please share your thoughts and publicize this forum to make our voice stand tall.


Default Alert Sound With Amplifier Issues

Woofers, Amplifiers, Head Units, Speakers and the likes...
Newbie TUVian
Posts: 1
Joined: 20 Feb 2018, 13:19
Location: New delhi
TUV 300 Varient: T8
Status: Offline

Default Alert Sound With Amplifier Issues

Postby ram2017 » 20 Feb 2018, 13:34

I have bought TUV 300, T8 last year in the month of April and within 3 days i got 4 channel amplifier installed along with base tube and tweeters. Everything was running good until i noticed, default alert sound increased incredibly which was not at all tolerable to human ear, for e.g: phone connected to Bluetooth and incoming bell rings, then seat belt alert, then tuv is in eco mode etc . I went ahead to Sri Durga service center where i initially bought this vehicle from and shared the concern, they have mentioned that infotainment is from Nikon and we have raised this concern earlier to them but received no response or resolution till date. Finally, i went back to the accessories vendor where i bought this from and then manually he has to turn down the output volume from amplifier. Obviously, which has destroyed the complete output of bass/trebble and vocals but had no other option. Effect of the audio is not that competent for sure which i have expected initially.

I need help if someone can advise what can be done to get this fixed.

Best Regards,
Rishi Chopra

Return to “In Car Entertainment (ICE)”

Who is online

Users browsing this forum: No registered users and 2 guests